Gift from my boss .. Lightwin

Home Forum Ask A Member Gift from my boss .. Lightwin

Currently, there are 0 users and 1 guest visiting this topic.
Viewing 15 posts - 1 through 15 (of 56 total)
  • Avatar
    Samuel Phelps

    US Member - 1 Year
    Replies: 171
    Topics: 24
    #188685

    The boss was checking out some pics of my Speeditwin the other day .. He said hey I got and old outboard sitting in the back of the warehouse I’ll give ya if you want it ..
    My first thought was please let it be a 35 hp Big Twin from the 50,s LOL!
    Not that but pretty cool gift anyway ! What year might this be ? Any info would be great ! Oil ratio ?

    IMG_0735

    IMG_0731

    IMG_0733

    Attachments:
    Avatar
    rvdriver

    US Member - 1 Year
    Replies: 57
    Topics: 13
    #188690

    Nice Engine. Just research the data plate.

    Attachments:
    Avatar
    rvdriver

    US Member - 1 Year
    Replies: 57
    Topics: 13
    #188692

    My 1958 Big Twin.

    bobw
    bobw

    US Member - 1 Year
    Replies: 1175
    Topics: 42
    #188693

    Samuel – model number on your motor says its a 1962 model.

    Bob

    1954 Johnson CD-11
    1956 Johnson RD-18
    1958 Johnson QD-19
    1959 Johnson QD-20
    1957 Evinrude Fastwin 18

    "Every 20 minute job is only a broken bolt away from a 3-day project."

    1 user thanked author for this post.
    Avatar
    garry-in-michigan

    Lifetime Member
    Replies: 3568
    Topics: 31
    #188700

    Considered one of the most trouble free outboards of the ’50s – it was built for almost 20 years without a major change. Look for cracked coils, replace the pump impeller and change the oil in the gear case.. It may have some residue in the fuel system, depending how it was prepared for storage. It called for a third of a pint to the gallon. It has all bronze bushings, but its OK to use the 50 to one oil, but at the 24 to one ratio. You can’t beat that price !

    Avatar
    Samuel Phelps

    US Member - 1 Year
    Replies: 171
    Topics: 24
    #188715

    Thanks guys for the info !
    rv , I’ll trade ya even Steven for your Bigtwin ! LOL!!! Beautiful motor !!!

    Avatar
    crosbyman

    Canada Member - 1 Year
    Replies: 1721
    Topics: 204
    Avatar
    Samuel Phelps

    US Member - 1 Year
    Replies: 171
    Topics: 24
    #188799

    Thanks so much Crosbyman !
    That is an awesome amount of information you posted .
    Now I just need the time to start digging in ..
    I,m on the lookout for a nice 14’ aluminum boat to run these motors on ..

    Avatar
    crosbyman

    Canada Member - 1 Year
    Replies: 1721
    Topics: 204
    #188815

    one great bible to have is t he Johnson manual found at the URL above this picture… This site (AOMCI) edits it out t but look on top of the picture and retype it on your search engine …… authorize your adobe to open it if needed

    another good read is CHEAP OUTBOARDS

    see carb picture for carb problem areas… open the top plug and clean the innards only if you have idle problems

    Joining AOMCI has priviledges 🙂

    • This reply was modified 11 months, 3 weeks ago by Avatarcrosbyman.
    Attachments:
    Avatar
    Samuel Phelps

    US Member - 1 Year
    Replies: 171
    Topics: 24
    #217433

    Hello back again .
    Had a minute to mess around with this motor .
    I am not getting any spark at all it seems . After taking the fw off and somewhat cleaning and setting the points no spark at all ..from the looks of the coils they kinda look like they have been replaced . I guess they still could be bad . I will take them off and attempt to check with an ohm meter .
    Should I look at anything else ?

    D1AECDEC-ABA6-4AF8-BD61-EBC02B603181

    • This reply was modified 3 weeks, 4 days ago by MumblesMumbles.
    Attachments:
    Avatar
    dave-bernard

    US Member - 2 Years
    Replies: 1247
    Topics: 17
    #217440

    most likely the condensers.

    Avatar
    Samuel Phelps

    US Member - 1 Year
    Replies: 171
    Topics: 24
    #217441

    I’m gunna order the ignition kit from the link that was posted above ..
    I just took the coils out .. The resistance on the the primary jumped around but both coils settled in on .4 ohms …
    The secondary I didn’t get a reading on either one . OL was the reading if I did it right …

    Avatar
    fleetwin

    US Member - 2 Years
    Replies: 3530
    Topics: 46
    #217453

    Nice Engine. Just research the data plate.

    beautiful!

    Avatar
    jeff-register


    Replies: 1235
    Topics: 50
    #217458

    Depending on your meter “OL” could mean overload or open line. Check at your highest resistance setting first, then drop down to the next lower setting. Like Dave say’s bad caps too. Primary winding should have very low resistance, secondary should be around 4K or so. Bad plug wires or connectors? No telling who has added their “Handi-work” to the mix!!
    Don’t assume these parts are good. I have found new electrical parts that were BAD too.

    Avatar
    crosbyman

    Canada Member - 1 Year
    Replies: 1721
    Topics: 204
    #217484

    where did you mesure the secondaries… at the end of the plug wire on on the screw pin inside the coils coils should read 4-7 kohms

    Joining AOMCI has priviledges 🙂

Viewing 15 posts - 1 through 15 (of 56 total)
  • You must be logged in to reply to this topic.